PostgreSQLの起動に失敗する際の対応
作成日:2023年4月12日 | 更新日:2023年4月17日
PostgreSQL起動失敗の発生例
PostgreSQL起動失敗の発生例は以下のとおりです。- 製品のアップグレード実行時、「Trying to start PostgresSQL server failed」のエラーが表示される。
- 製品起動時、「PostgresSQL server failed」のエラーが発生する。 (本エラーは<ADAudit Plus_インストールフォルダー>\logs\wrapper.logファイルに記載されます)
確認事項
PostgreSQLの起動に失敗した場合、以下3点をすべて確認してください。- ADAudit Plusサーバー上にて、アンチウイルスソフトウェアが起動していないか。 起動している場合、ADAudit Plusインストールフォルダーを、アンチウイルスソフトウェアのスキャン対象から除外してください。
- ADAudit Plusインストール先のディスクに、最低2GB以上の空き容量が確保されているか。 空き容量が2GB以下の場合、ディスク容量を増設をしてください。
- ADAudit Plusサーバー上にて、PostgreSQLがデフォルトで使用するポート33307を他のプロセスが使用していないか。 他のプロセスが使用している場合、他のプロセスの停止、または他のプロセスが使用するポート番号を変更してください。
手順
1. こちらのナレッジ内「A. 製品フォルダーのフルバックアップとリストア手順」の 「バックアップ手順」を参照し、ADAudit Plusのバックアップを取得バックアップ手順を実施することでADAudit Plusを完全に停止している場合、以下の手順2~5はスキップできます。
2. [services.msc]より、ADAudit Plusサービスを停止
3. 管理者としてコマンドプロンプトを起動し、<ADAudit Plus_インストールフォルダー>\binに移動
4. 以下のコマンドをそれぞれ実行stopADAP.bat stopDB.bat shutdown.bat5. タスクマネージャーを起動し、ADAudit Plus関連のプロセスが起動していないことを確認 起動している場合は停止してください(確認および停止手順はこちらのナレッジを参照)。 6. ADAudit Plusインストールフォルダーに対して、ユーザー「Authenticated Users」がフルコントロール権限を有するよう設定
同設定内容がADAudit Plusインストールフォルダー下のサブフォルダー・ファイルすべてに継承されていることをご確認ください。
7. 管理者としてコマンドプロンプトを起動し、<ADAudit Plus_インストールフォルダー>\binに移動
8. 以下のコマンドを実行initPgsql.bat Stonebraker
9. コマンド完了後、以下のコマンドを実行(データベース起動)
startDB.bat
データベース(PostgreSQL)の起動に失敗する場合
- コマンドプロンプトを終了
- ManageEngine Communityより弊社サポートに問い合わせ
- 以下の製品ログを送付(送付手順はこちらのナレッジを参照)
- <ADAudit Plus_インストールフォルダー>\logs
- <ADAudit Plus_インストールフォルダー>\pgql\data\pg_log
データベース(PostgreSQL)の起動に成功する場合
- 以下のコマンドを実行(データベース停止)
stopDB.bat
- PostgreSQLの起動失敗が原因で中断していた作業(製品アップグレードや製品起動)を再開
手順は以上です。